Jump to content
Sign in to follow this  
Guest Youka

Dial-A-Fix Deletes XP Limited Account Logon/Info

Recommended Posts

Guest Youka

When I run the "Repair Permissions" function of Dial-a-Fix (v 0.6.0.0.24), it deletes the Limited Account user logons from my opening XP Welcome Screen. In addition, these Limited Accounts are no longer listed under "User Accounts" on my PC [Control Panel | User Accounts].

Curiously, the actual files associated with this Limited Account [C:\Documents and Settings\"Limited Account"\*.*] seemingly remain intact.

Any suggestions for correcting this problem, and getting Dial-A-Fix to run correctly?

Dial-a-Fix was recommended to me as a possible solution for fixing a problem that I encountered while trying to install AVG 8.0.

Share this post


Link to post
Share on other sites

I just thought of this, and I've never tested it, but it just might work:

Open the following file in notepad:

C:\WINDOWS\INF\defltwk.inf

(This is the file "repair permissions" calls)

Find the following lines:

[Group Membership]

%SceInfUsers%__Memberof =

Add this after the equals sign: *S-1-5-32-545

It will now look like this:

[Group Membership]

%SceInfUsers%__Memberof = *S-1-5-32-545

Save the file, and run DAF's repair permissions again.

Warning: if I somehow misunderstand how this works then this could break something else. If you want to be safe, make a backup copy of SAM and SECURITY before proceeding. (You can Google "ERDNT" do make a full registry hive backup or use System Restore to set a restore point or something, I guess. More info at the Lunarsoft wiki in the System Volume Information article).

Share this post


Link to post
Share on other sites
Guest Guest

It turns out that the problem was a damaged XP user profile/account.

I was able to recover the damaged profile/account by creating a new account, and then copying over the user profile from the damaged account.

Everything seems fine now -- and Dial-a-Fix is running without incident.

Share this post


Link to post
Share on other sites

This has actually happened before... it turns out it is because the default template removes limited user accounts from the Users group, which is what my post above was about (replacing the group declaration in the INF). Have you tested it again with another limited user account? Am I to understand you are actually able to use repair permissions without it breaking limited user accounts now? o_O

Share this post


Link to post
Share on other sites
Guest Youka

Looks like I spoke too soon!

After repairing the damaged XP user profile, I neglected to change the status of the newly created account back to "Limited User" (from Computer Admin). So naturally, Dial-A-Fix's "Repair Permissions" ran just fine.

Once the status of the account was changed back, the problem ("Limited User" account no longer listed on "Welcome Screen" or under "User Accounts") returned.

A 2nd "Limited User" test account that I created was similarly affected.

I then implemented the "defltwk.inf" fix that you suggested, but the results were the same when I ran "Repair Permissions".

I'm open to any other suggestions.

Share this post


Link to post
Share on other sites
Guest Youka

As a follow-up . . .

In the System Volume Information Guide, it states that you can initiate the following commands to copy the SECURITY and SAM hives when "user accounts are no longer listed on the Welcome Screen:"

copy _REGISTRY_MACHINE_SAM \windows\system32\config\SAM

copy _REGISTRY_MACHINE_SECURITY\windows\system32\config\SECURITY

Two Questions:

1) If there are only a handful of RPx restore point folders listed (dating back over the 2 past weeks) – but the problem more than likely started several weeks ago and went unnoticed -- am I out-of-luck?

2) If copying SAM and SECURITY using this method resolves the problem, will it simply return when I re-run DAF "Repair Permissions" again?

NOTE: I'm running XP Home Edition (not XP Pro)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...