Jump to content
Sign in to follow this  
Jim

Dial-a-fix hangs at mmcndmrg.dll

Recommended Posts

Hi,

After having a major crash and the computer would barely work but it ran. I ran the SP2 repair (I think that is what it was called) and things came back up fine. Than I realized that window updater would not update and it caused some problems with Quicken. Quicken ran fine but when I tried to update information from the bank I got a denied message. When I went to quit Quicken windows installer wanted to uninstall it. Luckly it wasn't working.

I went out to a microsoft discussion group and found a topic called Cannot install updates - no error code in Windows Update which was what I was experiencing. They told me about dial-a-fix.

But since I am now having problems with dial-a-fix hanging I thought you would be my best chance for sorting this extremely annoying behavior out.

The long and the short of it is that dial-a-fix hangs at mmcndmgr.dll with external exception c0000006 @ registering mmcndmrg.dll. I ran the repair permissions tool and it hung at the same dll. I then started in safe mode using the instructions under registry permission issues which worked fine. I restarted ran dial-a-fix and the problem was still there.

What follows below are my communications with Microsoft discussion group. Let me know if you need more information and how to get it and send it to you.

Thanks much

Jim

=========Read from bottom up=======

I decided to go ahead with the registry permission issue procedure. It went

as described. However when I restarted and ran dial-a-fix it hung at the same

dill (mmcndmrg.dll) with the same error message error c0000006.

I should mention that the computer has started to hang at start up,

sometimes. It get past the log in fine, the virus program NOD32 starts ok.

Then shortly after the desktop appears I try to open a folder or on other

occasions to launch a program. The hour glass appears and the HD light goes

on and stays on and the machine doesn’t come out of it. I’ve waited up to 20

minutes then pulled the battery. Other times if I let it start, do nothing

for awhile it will operate fine. It seems to be a bit inconsistent.

Any suggestions

"peshkopi jim" wrote:

> Thank you for the instructions. I was able to complete the process and had 80

> updates to install and was able to run them-well almost all of them. Seven of

> them would not run. So I went to repeat the process hoping that would resolve

> the problem.

>

> Now when I run dial-a-fix it hangs at the registration center at

> explorer/ie/oe/shell/wmp. I get the error message external exception C0000006

> at mmcdmgr.dll. I had to force quit the application. I ran the tools repair

> permissions and it completed the process without any errors-several times.

> But when I run dial-a fix again (and again) it continues to hang at this dll

> file.

>

> I goggled the dill to see what it does and found UniblueRegistryBooster

> among others. I ran it and it indicated I had 876 errors and it could fix 15

> for free and to fix the rest I had to purchase it.

>

> I should mention that the first time I ran dial-a-fix it had the same

> external exception error c0000006 and hung at els.dll. I also had an “error 0

> was encountered while loading badlibrary (c/windows/system 32/mmcndmrg.dll.

> The error text is: The exception completed successfully” message. When I

> clicked ok the application proceeded to finish the scan without any other

> errors. I ran the repair tool, repair permissions, and it fixed the problem.

> I was able to run the full sweep of the application without any errors and

> complete these rest of the instructions and got the 80 updates.

>

> I am thinking of starting in safe mode as the instructions under the

> registry permission section and following these instructions but would like

> your thoughts and advice before proceeding.

>

> Also now when I go to the control panel and open administrative tools and

> try to launch computer management I get the error message “management console

> has encountered a problem and needs to close.”

>

> Thanks

> PJ

>

>

> "Shenan Stanley" wrote:

>

> > peshkopi jim wrote:

> > > I am having same problem. However I do not know how to install it

> > > using the command line switch. I guess I'm a GUI person. I have

> > > looked for a long time searching the web to see exactly how to do

> > > this but no where can I find all the commands put together. Could

> > > someone help me here?

> >

> > Save the file someplace simple - like the root of C:\

> >

> > Start button --> RUN --> CMD

> >

> > Now that you have a command prompt open, change directories to where you

> > saved the file...

> > (If you saved it to the root of C, and your prompt starts with

> > C:\something, type in:

> > CD \

> > and press enter.)

> >

> > type in the name of the executable, a space, and any command line options

> > you need to.

> >

> > --

> > Shenan Stanley

> > MS-MVP

> > --

> > How To Ask Questions The Smart Way

> > http://www.catb.org/~esr/faqs/smart-questions.html

Share this post


Link to post
Share on other sites

Test your memory and hard drive before doing anything else. The error code c0000006 is an "in-page" error which generally means either memory or hard drive problems.

MEMORY TESTERS:

http://memtest.org/

http://oca.microsoft.com/en/windiag.asp

Let them run for several hours.

HARD DRIVE TESTS:

If you are a bit savvy, you can try my article:

https://wiki.lunarsoft.net/wiki/Data_recovery

1) Download the RIPLinux live CD described under "Tools required" and burn it to a CD

2) Boot to the CD, login as root

3) fdisk -l (that's a lowercase L)

4) Find your hard drive and use smartctl and badblocks on it, as described in the article

If you are not savvy or do not feel like learning all of this stuff I suppose you could use Hitachi's DFT:

http://www.hitachigst.com/hdd/support/download.htm#DFT

Whatever software you use to test your drive, it needs to be bootable (so that you do not affect Windows) and has to be able to do long tests (of every sector on the drive).

Let us know if you need further assistance with these tools/instructions.

Share this post


Link to post
Share on other sites

First my apologies for posting a question in the introduction forum I will use the appropriate forum next time. Regarding introductions … I work in Albania for a Dutch international development agency trying to build the capacities of the national and local governments, civil society and business sectors. We mainly provide advisory services regarding income generation and the legal framework so people can earn enough money to live better lives. Currently most Albanians live on less that $2 a day. The work is challenging and when ones computer gets weird it becomes even more frustrating.

But I have solved the computers problems. At the Dell site I saw a post that said to run scannow which I see you also have posted here. That solved the problem and the updater updadted. I can now run dial-a-fix without it hanging. But an odd thing does occur when I run dial-a-fix. When it gets to explore/ie/oe/shell/wmp spyboat SD resident comes up telling me that it detects a browser value page change from google to msm search. I ran dial-a-fix 3 times and this occurred every time. Odd.

Concerned the HD taking forever to get going. In another forum a person indicated that they had a similar problem. It was related to a bad power supply not giving the proper voltage to the HD. That is my issue as my power supply has become very funky. I think this is due to the daily power outages, surges, and low voltage from the system. The computer power supply at times will make a crackling noise where the plug goes into the transformer. When I boot on battery I do not have that problem so I am getting another power supply.

Thanks for all your help!

Peshkopi Jim

Share this post


Link to post
Share on other sites

One of the things Dial-a-fix does is run ie4uinit.exe which changes that value Spybot is complaining about. I'll probably change this to be more prominent (as in the user decides whether Dial-a-fix runs this) in the next version. The ie4uinit repair has its merits so I left it that way and figured nobody would notice :cool:

Share this post


Link to post
Share on other sites

One of the things Dial-a-fix does is run ie4uinit.exe which changes that value Spybot is complaining about. I'll probably change this to be more prominent (as in the user decides whether Dial-a-fix runs this) in the next version. The ie4uinit repair has its merits so I left it that way and figured nobody would notice :cool:

Also note that this error code (c0000006) is an inpage error - not saying the hardware is bad, but the installation may be quite a ways gone at this point as applications are attempting to read pages into memory, either from disk or from the page file, and are failing to place said pages into memory (this time, I do actually mean RAM :cool: ):

# for hex 0xc0000006 / decimal -1073741818 :

  STATUS_IN_PAGE_ERROR										  ntstatus.h

# The instruction at "0x%08lx" referenced memory at

# "0x%08lx". The required data was not placed into memory

# because of an I/O error status of "0x%08lx".

Share this post


Link to post
Share on other sites

That's what I said, an inpage error :cool:

That error code is not anyone's friend (but err.exe is mine).

I know it doesn't guarantee that hardware is/has failed, but it's too frequently corrupted files from bad sectors or controller errors that start the issue in the first place. At least, on my bench. I get a lot of end-user computers which are mini biodome ecosystems of problems and mayhem. :cool:

Share this post


Link to post
Share on other sites

A strange thing is happening with the memory testers. The first when I create a boot cd opens in a dos mode looking for a drive. I type dir and see what they have . Run the exe file run through 6 or so pages of german before see a page to run something. I say something since it is all german and I don't understand it well enough to to let it loose on the computer. A strange thing is happening with these memory testers. The first one – after creating a boot cd opens in a dos mode looking for A drive. I type dir and see what they have. I run the exe file read through 6 or so pages of German before see a page to run something. I say something since it is all German and I don't understand it well enough to let it loose on the computer. Mummm??

The second link from Microsoft -- when I download the files and extract them as instructed and do the bootable cd thing gives me the exact same German program as the first. I’ve downloaded this 2x and rewrote it to a CD-RW. And this RW is different from the first one I created from http://memtest.org/

Even stranger.

Maybe I have some very serious viruses or ....

Can you help me out.

Share this post


Link to post
Share on other sites

Ok now I know my computer is really sick. I went to the hard drive site recommended (http://www.hitachigst.com/hdd/support/download.htm#DFT –going for the easier one as I am not a power player) and downloaded the iso file. Erased the CD-RW I used in the prior post using Nero and copied the iso file to it. I booted from it and the same program as mentioned before came up. The program is from Caldera, Inc. NLSFUNC R4.00.

The other laptop has gotten so sick that I have moved to our older Toshiba and am thinking the Dell is heading towards the junk yard. I have reseated the dimm chips thinking they had been bounced around and might have lost some contact. No luck there.

But I can’t even run the diagnostics since the same dang program keeps showing up.

Suggestions are appreciated.

PJ

Share this post


Link to post
Share on other sites

You're burning the CDs wrong, I believe. If you see caldera then you've enabled Nero's floppy drive bootable emulation stuff. Don't choose to make a bootable CD compilation at all.

Open Nero, close any sub-window it opens (such as New Compilation), and click Recorder on the top pull down menu and choose Burn image...

Share this post


Link to post
Share on other sites

Yes you are correct I was burning the cd wrong. I followed your instructions and am now happily running memory tests. Hopefully I’ll find out what is wrong with the machine. And hopefully be able to fix it.

Thanks again for your help.

PJ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×