Jump to content

"windows cannot access the specified device path or file.

Guest Steven Avery

Recommended Posts

Guest Steven Avery

Hi Folks,


Appreciate your tools and forum, new to them today.

Normally my XP-SP3 puter has 2 users in addition to the Administrator, and there are to be no restrictions.

Today: lots of .exe initiation problems

Permissions -

"windows cannot access the specified device path or file. you may not have the appropriate permission to access the item"


Safe Mode and Administrator signon.

(Possibly Safe Mode and regular sign-ons are ok, I have not tested, Administrator signon outside safe mode hits the same problems.)

This seemed to arise after last nights Windows IE8 hotfix (Note: before this, in general my IE8 does not want to open, simply flashes up and down, which doesn't bother me normally as I use the other browsers). Somehow I had the puter set to automatic updates. System Restore I don't have up at this time. In a super-pinch I can always reformat, losing a couple of hours of time, however I would like to try to fix this permission thing, learning in the process.

Malwarebytes runs a complete scan, finds the system clean. For my Avira scan to run fully I would have to return to Safe mode, since it is one of the .exes that is asleep (just the scan, the guard is up). I would do special testing (BitDefender, Panda, etc) looking for trojans in safe mode if I thought that were the root of the problem, or just as additional check. The fact of the 3AM Windows Update install though was confirmed in event viewer and an automatic update setting (since changed, plus put system restore back on for the future).

(SIDENOTE: in safe mode the monitor or video driver doesn't load so the system is a bit balky around the edges of scrolling web pages, so I wonder if there is an easy way to load a video driver once you go into safe mode .. Dell monitor, I can find the driver location. Another funny thing is that the printer server did not want to load in safe mode, although it works fine in my regular mode).


So I tried Dial-a-Fix in the "Permissions" thing.

Gives two nice log files.

secanalyze 500K and has lots of entries starting with stuff like:

----Reading Configuration Info...

----Analyze Group Membership...

Analyze Replicator.

Analyze Remote Desktop Users.

Analyze Power Users.

Analyze Network Configuration Operators.

Analyze Guests.

Not Configured - *S-1-5-32-546__Members.

Analyze Backup Operators.

Analyze Administrators.

Not Configured - *S-1-5-32-544__Members.

Analyze Users.

Mismatch - *S-1-5-32-545__Members.

That is curious.


423 mismatches are found under machine.

2726 mismatches are found under c:\.

Many of those mismatches are IE8 related.

Stuff is a bit crytpic, so I will leave it like this for now. Can include the file or extract more.

Then to secrepair.log.

Here is some of the curious stuff.

----Configure User Rights...

Configure S-1-5-21-1202660629-1364589140-682003330-1002.

remove SeBatchLogonRight.

remove SeDenyNetworkLogonRight.

remove SeDenyInteractiveLogonRight.

Configure S-1-5-19.

Configure S-1-5-20.

remove SeServiceLogonRight.

Configure S-1-5-32-544.

Configure S-1-5-32-551.

Configure S-1-5-32-547.

Configure S-1-5-32-545.

Configure S-1-1-0.

Configure S-1-5-4.

Configure S-1-5-6.

Configure S-1-5-21-1202660629-1364589140-682003330-501.

Configure S-1-5-32-555.

User Rights configuration was completed successfully.

----Configure Group Membership...

Configure Users.

remove DELL-PRECISION\Steven.

remove DELL-PRECISION\OtherName.

Group Membership configuration was completed successfully.

The rest is all stuff like.

Configure c:\windows\system32\inetcpl.cpl.

With a few like this:

Warning 2: The system cannot find the file specified.

Error setting security on c:\windows\system32\ieencode.dll.

File Security configuration was completed successfully.

General Service configuration was completed successfully.

The next section begins like this:

---Configure Security Policy...

Configure password information.

LSA anonymous lookup names setting : existing SD = D:(D;;0x800;;;AN)(A;;0xf1fff;;;BA)(A;;0x20801;;;WD)(A;;0x801;;;AN)(A;;0x1000;;;LS)(A;;0x1000;;;NS).

Configure LSA anonymous lookup setting.

Guest account is disabled.

System Access configuration was completed successfully.

Configure log settings.

Audit/Log configuration was completed successfully.

Configure machine\software\microsoft\windows nt\currentversion\setup\recoveryconsole\securitylevel.

And the ending is:

Configuration of Registry Values was completed successfully.

----Configure available attachment engines...

Configuration of attachment engines was completed successfully.

----Un-initialize configuration engine...

Any thoughts appreciated.

When I was done, the permission problem appears unchanged.


Note, no action on the D:\ where i have data only .. all my active programs are on the C:\



.exe file association corruption is another possbility - it looks like the Doug Knox tool may be the way to go to look into that. I have not tried that yet.

Uninstalling the IE8 patch is another try, one that I haven't tried yet.


Your ideas and thoughts for an all-purpose way.



Steven Avery

Link to comment
Share on other sites

Guest Steven Avery

Hi Folks,

Yes, I could function properly opening .exe in any user in safe mode, making me think the problem is more on the file permissions than the user permissions. And I realized that the reason my Firefox started blocking was it also had an update, meaning that new files were coming in with a blocked mode.

My current attempt (WIP) involves what is expressed here with the Group Policy Editor, even though I dunno if I ever got this exact message of the thread title.

"This file came from another computer and might be blocked to help protect this computer".


Enable: Do not preserve zone information in file attachments

Will report back how that goes.

My other attempt is simply involving file sharing, however since that is more network than users within a PC I doubt it matters.

Thus if this is not user permissions, which by strong circumstantial evidence it is not, that would explain why Dial-a-Fix did not effect the original issues.


Steven Avery

Link to comment
Share on other sites

Guest Steven Avery

Hi Folks,


While that zone does not seem to make a difference (a newly downloaded file, after the zone change, still did not open, msg the same). Btw, a .pdf downloads and opens fine. Meanwhile, I noticed something else that any potential troubleshooter might want to know.

If I go to "User Accounts" in the Control Panel -- not in safe mode, adminsistrator or user -- I get the same permissions msg as the forum thread name. Thus the problem always exists outside of safe mode, and it includes even a system file, or two (the modem entry and Nividia control panel and Internet connection gave similar, while about 10 others worked fine ).

Conceivably, these system files User Accounts file could be updated in nightly Windows update -- I could check the file dates, is one unusual thought.

So do any of the techies here, more familiar with this stuff, have a lead on unravelling why safe mode runs fine, but all accounts in normal mode would have all these permission problems, on .exe .. especially NEW .exe. As described.

Thanks :-)

For now I can function combinging the two modes, safe mode for downloading and new files, and regular mode for quick action browsing and such. However it is of course a tad cumbersome. It is fascinating to discover the various little side-swipes in XP.


Steven Avery

Link to comment
Share on other sites

Just going out on a limb here, but does Avira have any file permissions windows?

cause from what i gather, the computer boots up fine in normal mode, runs the necessary files, but after something loads(Avira for example) you can no longer run them.

So i'd recommend looking around in Avira to see if theres any permissions settings, and making sure the trusted windows apps all have their permissions set to Allowed. (Explorer.exe, regedit.exe, cmd.exe, etc..)

Link to comment
Share on other sites


Yep. You just about nailed it, I had just found the problem and saw your post. Not Avira (which I uninstalled my free and it did not matter, now will likely reinstall, no biggie, nice program) but Online Armor .. also usually a friendly program .. needed a reset of sorts. Somehow it had lost part of its registration serial number and brain, and I simply refound the icon (the processes were running without the systray), unticked the protection, reregistered, reticked and answered a couple of prompts and all looks fine. Likely OA lost its brain related to the IE8 hotfix update .. or something.

As soon as I did that, my Firefox was working fine and I could execute the programs which had failed. And I can go into user accounts, etc. Looks like OA may have lost some of its remembrance of earlier prompts, or something like that, but that is no problem. I never mind one-time prompts, even a second time !

So my big problem seems to be over. A few hours, a lot of learning. Some frustrations, but not enough to force the immediate Linux overhaul :-) . In the midst of that I tried to uninstall IE8 using a command line .. it was a bit more complicated since my IE8 was put in before SP3 .. now I may try to reinstall .. hopefully I can actually get the IE8 up, and then locked down. Also, I still wonder about the video driver in safe mode. In any future problem I would feel more confident if same mode worked a little smoother. (And I could change monitors)

Lunarsoft .. you have a nice forum here, your thinking was spot-on (that was why I emphasized full power in safe mode versus hassles in normal mode - to help reason together ! ).

There are a lot of threads on this issue, since about 5 different major causes can be involved. This is the most diverse one, on a server forum, but a lot of the folks were straight XP.

Windows cannot access the specified device, path, or file.


And I may post there about the experience.

For now I am a happy camper.

Thanks again. Hope to be in communication about this and that.


Steven Avery

Link to comment
Share on other sites

Thanks, Steven, for a most informative post on solving your issues.

Related to some of the questions Steven has raised, there is a general side issue that will affect others:

"This file came from another computer and might be blocked to help protect this computer"

was introduced with Windows XP Service Pack 2. A very long, but informative, explanation is given by Microsoft in the support KB, at: Description of how the Attachment Manager works in Windows XP Service Pack 2.

In all cases, the usual workaround is to right-click on the file and click on the big "Unblock" button at the bottom-right of the tab.

Firefox now respects these permissions (since Fx 3.0, I think) and, in Firefox 3.5, is much more difficult/impossible to disable.

A bug has been filed for Fx 3.5 & 3.6. Full details (including a workaround which involves editing the Registry AND about:config) are at: https://bugzilla.mozilla.org/show_bug.cgi?id=499448.


Link to comment
Share on other sites

Glad to hear you got it resolved.

And nice to see that i still have a nose for this stuff. I don't normally answer any tech problems on forums anymore because it's rare to find detailed information.


Link to comment
Share on other sites

  • 1 year later...

Thank you so much! Ive been searching for a fix to this problem for two days and it turns out my problem was Online Armor as well. Most other solutions I was reading about involved servers and what not which dont apply to my computer.

Much appreciated :P

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...