Jump to content

Archived

This topic is now archived and is closed to further replies.

krit86lr

Gpedit.msc

Recommended Posts

Hey y'all,

So Microsoft has been trying to fix errors that are appearing in Event Viewer. Today they emailed me with a new solution.

GPedit.msc - Local Computer Policy - Computer Config - Windows Setting - Security Settings - Local Policies - Security Options

DCOM: Machine Access Restrictions -

Anonymous Logon - Local Access (enabled)

Everyone - Local Access (enabled) - Remote access (enabled)

First of all I didn't have choices between Anonymous/Everyone. I typed something wrong, and my computer kinda works now. It won't let me change the settings again to type the correct information. System Restore won't open. I can only navigate through Task Manager, because I don't have a Taskbar anymore. CTRL + ESC doesn't open the start menu.

MS Support says new install, but my install isn't even 2mos old yet, and I'm not in the mood to loose everything again. I can't back anything up to a CD (don't know why) the service is started.

I've done, repair console...DAF. Any suggestions would be lovely!

punk.gif Good Times Baby :cry:

Share this post


Link to post
Share on other sites

Just for fun here are some more. :D This is so exciting <sarcasm>

Windows cannot connect to the defragment engine.

I can't send emails because it tells me that I don't have enough memory. Yesterday I had 70% free space on my HD. (maybe they're not related...I don't know).

I can't think of any more joy to bring to this thread at the moment, but when I come across some more I'll be sure to let you know.

:cry:

Share this post


Link to post
Share on other sites

Could always try using the green checkmark in DAF and hitting Go.

Is Safe Mode any different/better?

<{POST_SNAPBACK}>

I tried both already. :cry:

Share this post


Link to post
Share on other sites

I'm going to ask a few techs and see what they think. I know you hate to format, but I'm somewhat agreeing with MS that it might be the better option. Sure, these errors might get fixed, but more could arise.

Share this post


Link to post
Share on other sites

I'm going to ask a few techs and see what they think.  I know you hate to format, but I'm somewhat agreeing with MS that it might be the better option.  Sure, these errors might get fixed, but more could arise.

<{POST_SNAPBACK}>

How can I fix the DCOM: Machine Access Restrictions? I entered in something wrong, and that's when my problems began. Now I'm locked out, even as Admin, and I can't change it to the correct entry. I'm positive that I just need to get the Access Restrictions to open so that I can fix it. Why won't it open?

Thanks, :cry:

K

Share this post


Link to post
Share on other sites

...GPedit.msc - Local Computer Policy - Computer Config - Windows Setting - Security Settings - Local Policies - Security Options

DCOM: Machine Access Restrictions -

Anonymous Logon - Local Access (enabled)

Everyone - Local Access (enabled) - Remote access (enabled)

First of all I didn't have choices between Anonymous/Everyone.  I typed something wrong, and my computer kinda works now.  It won't let me change the settings again to type the correct information.  System Restore won't open.  I can only navigate through Task Manager, because I don't have a Taskbar anymore.  CTRL + ESC doesn't open the start menu...

<{POST_SNAPBACK}>

The first problem is that MS didn't give you very good instructions. You need to click the 'Edit Security...' button to access those options. Here is a screenshot.

gpedit.png

That will let you Allow your Local and Remote Access. Do you remeber what it was that you typed in the 'Security descriptor' box that wreaked havoc with Windows?

As far as Windows saying you don't have enough memory, that is referring to your RAM, not your hard drive.

Have you tried bringing up Task Manager, clicking File, selecting 'New Task (Run...)', and entering in "explorer.exe" (no quotes)? If explorer isn't starting automatically, manually telling it to run may bring up your Windows GUI.

Since the errors you have been receiving are very strange, I would recommend reinstalling Windows over top of your current install, but don't do a clean install. This way, you would keep your files, and Windows would be fixed (hopefully). The only problem would be that you would have to redownload your Windows Updates, which is a small price to pay.

Share this post


Link to post
Share on other sites

Thanks lokoike. The email that MS sent me didn't give me good instructions, and that was my first time using GPedit, and I'm officially not a fan. :D

I've been working on a paper, and only slept for 1hr last night, so I'll find what I typed tomorrow. I'm tooooo tired to look.

As for my ram I have 640MB which should be fine. I did notice however that my CPU kept jumping from 1% to 100% about every 2 seconds.

I actually just saw your post, and I just finished formatting, and a clean install. In the past I could use the upgrade feature, and not lose my settings but this time it only gave me a format option.

Even though I'm not a fan of GPedit right now I do want to learn more about it so that I don't make the same mistake again.

My computer is very happy now!

:cry:

(I love that boogie guy :) )

Share this post


Link to post
Share on other sites

Well, glad you have it working now! Sorry that you had to format, though. :D

I hardly ever even mess with Gpedit, cause I've only have XP Pro for a couple months now. Before that, I used XP Home, which doesn't even have the Gpedit utility.

One thing I forgot to mention is that the settings MS suggested are the default settings anyway, so you most likely already had that configuration in the first place! :cry:

sorry, saying that probably isn't making it any better!

640 MBs is more than enough, so Windows was giving you a false message. The minimum RAM requirement for XP (Home, anyway) is 64 MB, so technically, you have 10 times more RAM than is required!!! Of course, that said, I wouldn't touch a computer that has XP installed with any less than 512 MBs. MS's minimum specs are a joke.

As far as the CPU usage goes, could you tell what process was making it spike like that? Just curious, really doesn't make any difference now.

Glad your computer is healthy now! doctor.gif

Share this post


Link to post
Share on other sites

Well, glad you have it working now!  Sorry that you had to format, though. ;)

Me too, but school is in full swing right now so I couldn't wait to have a functioning computer.

One thing I forgot to mention is that the settings MS suggested are the default settings anyway, so you most likely already had that configuration in the first place! :D

Darn FTW's. :)
MS's minimum specs are a joke.
Agreed.

As far as the CPU usage goes, could you tell what process was making it spike like that?

No, everytime I opened Task Manager different processes were running which made it very difficult to pin down the little sucker.
Glad your computer is healthy now!

Me too...thanks. :cry:

Share this post


Link to post
Share on other sites

Edit to previous post:  My Quotes are backwards!  :cry:

<{POST_SNAPBACK}>

Those quotes sure give you a hell of time, don't they?! :D

Of course, I really can't poke fun, cause it took me about 600 posts on the CCleaner forum before I figured out how to get the to work! mestupid.png

Share this post


Link to post
Share on other sites

Edit to previous post:  My Quotes are backwards!  :cry:

<{POST_SNAPBACK}>

Those quotes sure give you a hell of time, don't they?! :D

Of course, I really can't poke fun, cause it took me about 600 posts on the CCleaner forum before I figured out how to get the to work! mestupid.png

<{POST_SNAPBACK}>

haha...I was too lazy to fix it. :)

Share this post


Link to post
Share on other sites

Edit to previous post:  My Quotes are backwards!  :D

<{POST_SNAPBACK}>

Those quotes sure give you a hell of time, don't they?! :)

<{POST_SNAPBACK}>

It's strange because it wasn't a problem when I first started posting, and now I keep messing it up. :cry:

Share this post


Link to post
Share on other sites

Alright! Here's the feeback on what not to do in GPedit.msc.

DO NOT adjust the "location" for "object type". If you do then you will be asking for a clean install of your OS. <beware> :)

location = local computer, computer name, etc...

object type = users, groups, and/or built-in security principles.

As for me...I will not be visiting GPedit anytime in the near future. :cry:

This all started because I had customized all of my access restrictions on my computer, and an evil little MS update came along that was not compatible with my customizations. Microsoft then instructed me (vague instructions) to change settings in GPedit to fix the errors/compatibility issues, and I made a mistake in changing the settings.

Hope this helps someone else from making the same mistake. :D

Share this post


Link to post
Share on other sites

Sure, these errors might get fixed, but more could arise.

<{POST_SNAPBACK}>

You were right. More problems kept popping up by the minute. Formatting became a welcomed solution. :cry:

Share this post


Link to post
Share on other sites

×
×
  • Create New...