Jump to content

Archived

This topic is now archived and is closed to further replies.

puzzlefixer

.Net Framework problem (I think)

Recommended Posts

Am helping a friend who has an HP Pavilion circa 2006. First, Windows became corrupted, so he ran the recovery disks that he made when the computer was new. It installed the original programs (with all the garbage programs they put on computers back then). I then helped him download and run most of the Win XP updates (thru SP3) and reinstall MS Office 2003 and other programs he wanted.

Everything seemed to go well until today when Microsoft Update notified him that more updates had been downloaded and were ready to install. Started the installation. Program was .Net Framework 3.5 w/ SP1; .NF 1.1 was already on the drive, and yesterday we installed .NF 2.0 in order to run FileHippo Update Checker. Attempted installation of 3.5 failed. Tried rebooting, tried uninstalling .NF 1.1, removed all temp files using %temp%, checked the Download folders (nothing in them), ran an "sfc /scannow" to see if any windows files were corrupted or missing (were not). Nothing allowed .NF 3.5 to install.

Saw a Microsoft forum thread where the writer said that if the computer ever had Norton Security on it, it could be causing the problem. It had been on the computer. I thought I got rid of it yesterday, but opted to download their uninstaller and run it to find any remnants (which it did). .NF still would not install.

Even worse, now when you go to shut the computer down, there's the message on it to shut it off and Windows will install a program. Click Turn Off. Get "Installing 1 of 1. . .", but it never installs. Have to shut it off using the power button. Now it does bizarre things, like if you do a Search, and click All Files and Folder, it crashes Explorer and regenerates the desktop.

During the several attempts to install .NF, got this error message: ngen.exe - Application error. The instruction at 0x79034524 referenced memory at 0x00000000. The memory could not be read." Also at various times got "Microsoft Common Language Runtime native compiler has encountered a problem and needs to close" followed within a few seconds by "Setup.exe has encountered a problem and needs to close."

What's wrong/what do I need to do to get this &*(^% thing working again short of recovering the OS again and starting all over?

Share this post


Link to post
Share on other sites

.NET can be a complete pain to fix when/if it goes wrong.

Always follow advice from Aaron Stebner (see Tarun's link) when you have problems.

You need to:-

  1. Remove ALL .NET frameworks using Aaron's Uninstaller (again, see Tarun's link)
  2. Install .NET 3.5 SP1. Do NOT attempt to install .NET 2.0 or .NET 1.1 first
  3. Microsoft Update will immediately want to install the .NET 3.5 SP1 Family Update (KB958481/3/4)
  4. Then you can install .NET 1.1 Again, do NOT attempt to install.NET 2.0
  5. Run Microsoft Update to ensure that that the .NET 3.5 update has installed, then all the updates to the updates.

Usefull links:-

Why does Windows Update continue offering the .NET Framework 3.5 SP1 after I install it?

Should I re-install the versions of the .NET Framework in a specific order?

If the Microsoft Update continues to give problems, more reliable installs can sometimes be achieved by downloading the Standalone updates from the Microsoft Download Center and installing them in the correct order (which is by order of release date)

Installing .NET updates in the wrong order (i.e. NON-date-order) can also lead to failure.

.

Share this post


Link to post
Share on other sites

×
×
  • Create New...