Jump to content
Axmonkey

Error when Starting Toolkit

Recommended Posts

When I start the Anti-Malware Toolkit I get the error:

"Configuration system failed to initialize"

Then the program will start, but there's no info in the packages area....

I was running an older version, so I updated to the newest, same thing.

Share this post


Link to post
Share on other sites

Details hmm...there's not too many really.

Double click Icon, Box pops up with the error text, a red circle with a white X in it, and OK button, and the window title is "Anti-Malware Toolkit". I press OK and the toolkit starts, but the drop down and all the boxes are blank except for "Download Path" .

As for .net, 1.1, 2.0 SP2, 3.0 SP2 and 3.5 SP1

Share this post


Link to post
Share on other sites

Looks to me like you are either trying to use the program whilst offline or something is blocking it from accessing the internet, such as a firewall.

Share this post


Link to post
Share on other sites

I'm currently working on improving the error handling system, which will be out in 1.10 and 1.11.

As Capman mentioned, if you're using a firewall make sure AMT has access to the Internet.

Do you continue to get the error if you hit F5 once that main program has loaded? Have you tried doing a clean install of the toolkit?

Share this post


Link to post
Share on other sites

Turning the firewall "off" is not the right approach - often you're just turning off the user interface, the firewall continues to block stuff. What firewall are you using?

Share this post


Link to post
Share on other sites

Axmonkey,

I had the same problem ... I racked my brain for a bit and figured it out, well the fix to my problem that is. Do you connect through a proxy server, here at my work we do, once I made the necessary changes in IE everything was ok.

Hope this helps,

Hunter

post-1265-1242312187_thumb.jpg

Share this post


Link to post
Share on other sites

i think hunter0512 nailed it. more then likely you connect through a proxy normally, in which case it can't access lunarsoft.net for the applications file.

if this is the case, i'll see about coding in a command line argument or proxy-config gui form for people depending upon what Tarun decides.

Currently i'm fine tuning the code for operating system and architecture detection. but if entering in the proxy information fixes it i'll see if i can code it before 1.10's release..

Share this post


Link to post
Share on other sites

Synapse,

That's what I thought the problem was. I tried it here at work and that did correct the issue. Tarun and everyone involved; thanks for a great program, let me know if there is anything I can do to help. :D

Hunter

Share this post


Link to post
Share on other sites

Synapse,

That's what I thought the problem was. I tried it here at work and that did correct the issue. Tarun and everyone involved; thanks for a great program, let me know if there is anything I can do to help. :D

Hunter

thanks for the reply and glad that solved it.

The code we're currently uses inherits the proxy settings from IE, which is why changing the proxy info for IE fixes it..

I'm currently fine-tuning the proxy stuff to get it working completely so it will be in a future release. Just gotta work out the bugs.

Share this post


Link to post
Share on other sites

Turning the firewall "off" is not the right approach - often you're just turning off the user interface, the firewall continues to block stuff. What firewall are you using?

I'm using zonealarm and the toolkit is allowed to access to the "trusted" and "internet" zones. I'm a fairly competent user so disabling a firewall is not a problem. This is a home PC, and there's no proxy defined in IE, not that I use it. Unfortunately I've been a bit busy lately and haven't had a chance to mess with .net.

Share this post


Link to post
Share on other sites

Ok; probably not a firewall problem then. My reaction was influenced by the dozens of posts I've seen on the Firefox forums, where perplexed users said "I turned off the firewall, but it still doesn't work". Just wanted to make sure you weren't making the same mistake - apparently you're not.

Share this post


Link to post
Share on other sites

Turning the firewall "off" is not the right approach - often you're just turning off the user interface, the firewall continues to block stuff. What firewall are you using?

I'm using zonealarm and the toolkit is allowed to access to the "trusted" and "internet" zones. I'm a fairly competent user so disabling a firewall is not a problem. This is a home PC, and there's no proxy defined in IE, not that I use it. Unfortunately I've been a bit busy lately and haven't had a chance to mess with .net.

Okay since it's not an issue with your firewall and you're not running through a proxy, have you checked your AMT settings? Perhaps you have Use Proxy checked?

Share this post


Link to post
Share on other sites

Nope nothing checked in the settings except "check for updates"

Loaded the new version. Now I get some additional text in that error box.

"An error occurred parsing the XML:" next line " Configuration system failed to initialize"

settings.xml exists in the toolkit folder with the text below. Hmm do you think something is blocking the XML code from executing? When I double click on it, IE is gives one of those gold bars about "it's restricting this file from showing active content". I'm using IE 6 BTW.

<?xml version="1.0" encoding="UTF-8"?>
<settings>
<Program>
<UseCategories>False</UseCategories>
<SaveDownPath>False</SaveDownPath>
<DownloadPath>
</DownloadPath>
<OpenDownFolder>False</OpenDownFolder>
<AutoUpdate>True</AutoUpdate>
</Program>
<Proxy>
<UseProxy>False</UseProxy>
<ProxyAddress>
</ProxyAddress>
<ProxyPort>
</ProxyPort>
<ProxyAuth>False</ProxyAuth>
<ProxyUsername>
</ProxyUsername>
<ProxyPassword>
</ProxyPassword>
</Proxy>
</settings>

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...